MapImagerySettings Class

Provides access to the map imagery settings (Base and layers). In earlier versions only a background map was supported as specified by the providerName and mapType members of BackgroundMapSettings object. In order to provide backward compatibility the original BackgroundMapSettings are synchronized with the MapImagerySettings base layer as long as the settings are compatible.

Methods

Name Description
toJSON(): MapImageryProps    
fromJSON(imageryJson?: MapImageryProps): MapImagerySettings Static Construct from JSON, performing validation and applying default values for undefined fields.  

Properties

Name Type Description
backgroundBase Accessor BaseLayerSettings The settings for the base layer.  
backgroundLayers Accessor ReadOnly MapLayerSettings[]    
overlayLayers Accessor ReadOnly MapLayerSettings[]    

Defined in

Last Updated: 16 April, 2024