RenderMaterialAssetProps Interface

Describes the graphical properties of a RenderMaterialElement as part of a RenderMaterialProps. This representation is used to persist the material properties into the IModelDb, but is unwieldy and verbose.

@see RenderMaterialElementParams for a somewhat more ergonomic representation.

Properties

Name Type Description
HasBaseColor boolean | undefined If true, this material has a fill/diffuse color; if undefined, defaults to false  
HasDiffuse boolean | undefined If true, this material has a value for diffuse reflectivity; if undefined, defaults to false  
HasFinish boolean | undefined If true, this material has a specular exponent; if undefined, defaults to false  
HasReflect boolean | undefined If true, this material has a value for environmental reflectivity; if undefined, defaults to false  
HasReflectColor boolean | undefined If true, this material has a surface reflectance color; if undefined, defaults to false.  
HasSpecular boolean | undefined If true, this material has a value for specular reflectivity; if undefined, defaults to false.  
HasSpecularColor boolean | undefined If true, this material has a specular color; if undefined, defaults to false  
HasTransmit boolean | undefined If true, this material has surface transparency; if undefined, defaults to false  
Map RenderMaterialAssetMapsProps | undefined An optional set of texture maps associated with this material.  
color RgbFactorProps | undefined Surface color used for fill or diffuse illumination; if undefined, defaults to black  
diffuse number | undefined Surface diffuse reflectivity; if undefined, defaults to 0.6  
finish number | undefined Specular exponent (surface shininess); range is 0 to 128; if undefined, defaults to 13.5  
pbr_normal number | undefined A scale by which to multiply the components of the normals read from Map.Normal, if a normal map is defined.  
reflect number | undefined Surface environmental reflectivity; stored as fraction of specular in V8 material settings; if undefined defaults to 0.0  
reflect_color RgbFactorProps | undefined Surface reflectance color; if undefined, defaults to black  
specular number | undefined Surface specular reflectivity; if undefined, defaults to 0.4  
specular_color RgbFactorProps | undefined Surface color used for specular illumination; if undefined, defaults to black  
transmit number | undefined Surface transparency; if undefined, defaults to 0.0  

Defined in

Last Updated: 13 May, 2024