ClipStyle Class

Describes symbology and behavior applied to a ClipVector when applied to a ViewState or ModelClipGroup.

@see DisplayStyleSettings.clipStyle.

Methods

Name Description
toJSON(): undefined | ClipStyleProps The JSON representation of this style.  
create(style: ClipStyleCreateArgs): ClipStyle Static Create a style from its components.  
create(produceCutGeometry: boolean, cutStyle: CutStyle, insideColor?: RgbColor, outsideColor?: RgbColor): ClipStyle Static   Deprecated  
fromJSON(props?: ClipStyleProps): ClipStyle Static    

Properties

Name Type Description
colorizeIntersection Readonly boolean If 'true', intersection of geometry and clip planes will be colorized  
cutStyle Readonly CutStyle Controls aspects of how the cut geometry is displayed, if ClipStyle.produceCutGeometry is true.  
defaults StaticReadonly ClipStyle The default style, which overrides none of the view's settings.  
insideColor Readonly undefined | RgbColor If defined, geometry inside the clip planes will be drawn in this color.  
intersectionStyle Readonly undefined | ClipIntersectionStyle Controls the style of the intersection of geometry and clip planes  
matchesDefaults Accessor ReadOnly boolean Returns true if this style matches the ClipStyle.defaults - that is, it overrides no settings from the view.  
outsideColor Readonly undefined | RgbColor If defined, geometry outside of the clip planes will be drawn in this color instead of being clipped.  
produceCutGeometry Readonly boolean If true, geometry will be produced at the clip planes.  

Defined in

Last Updated: 16 April, 2024