ElectronHost Class

The backend for Electron-based desktop applications

Methods

Name Description
getWindowMaximizedSetting(windowName: string): undefined | boolean Static Gets "window maximized" flag for a window, by name, from settings file if present  
getWindowSizeAndPositionSetting(windowName: string): undefined | WindowSizeAndPositionProps Static Gets window size and position for a window, by name, from settings file, if present.  
getWindowSizeSetting(windowName: string): undefined | WindowSizeAndPositionProps Static Gets window size and position for a window, by name, from settings file, if present. Deprecated  
openMainWindow(windowOptions?: ElectronHostWindowOptions): Promise<void> Static Open the main Window when the app is ready.  
startup(opts?: ElectronHostOpts): Promise<void> Static Initialize the backend of an Electron app.  

Properties

Name Type Description
app Accessor StaticReadOnly App    
appIconPath Static string    
electron Accessor StaticReadOnly undefined    
frontendURL Static string    
ipcMain Accessor StaticReadOnly IpcMain    
isValid Accessor StaticReadOnly boolean    
mainWindow Accessor StaticReadOnly undefined | BrowserWindow The "main" BrowserWindow for this application.  
rpcConfig Static RpcConfiguration    
webResourcesPath Static string    

Defined in

Last Updated: 16 April, 2024