TextSelectFormatPropEditorSpec Interface

TextSelectFormatPropEditorSpec defines getter and setter method for a Select/Dropdown property editor.

Extends

Properties

Name Type Description
editorType "select"    
getString (props: FormatProps) => string    
selectOptions { label: string, value: string }[]    
setString (props: FormatProps, value: string) => FormatProps    

Inherited properties

Name Type Inherited from Description
label string CustomFormatPropEditorSpec  

Defined in

Last Updated: 16 April, 2024