MeshArgs Namespace

Defined in

MeshArgs Interface

Arguments supplied to RenderSystem.createTriMesh describing a triangle mesh.

Properties

Name Type Description
auxChannels undefined | Auxiliary data associated with the mesh.  
colors ColorIndex The color(s) of the mesh.  
features FeatureIndex The Feature(s) contained in the mesh.  
fillFlags undefined | FillFlags If MeshArgs.isPlanar is true, describes how fill is applied to planar region interiors in wireframe mode.  
hasBakedLighting undefined | boolean If true, indicates that the mesh has a texture that includes static lighting - e.g., from photogrammetry.  
is2d undefined | boolean If true, indicates that the mesh is two-dimensional - i.e., all MeshArgs.points have the same z coordinate.  
isPlanar undefined | boolean If true, indicates that the mesh represents a planar region.  
material undefined | RenderMaterial The material applied to the mesh.  
normals undefined | OctEncodedNormal[] The per-vertex normal vectors, indexed by MeshArgs.vertIndices.  
points QPoint3dList | Point3d[] & { range: Range3d } The positions of the mesh's vertices, indexed by MeshArgs.vertIndices.  
textureMapping undefined | { texture: RenderTexture, uvParams: Point2d[] } A texture mapping to be applied to the mesh.  
vertIndices number[] The indices of the triangles.  

Defined in

Last Updated: 15 March, 2024