ParticleCollectionBuilderParams Interface

Parameters used to construct a ParticleCollectionBuilder.

Properties

Name Type Description
isViewCoords undefined | boolean If true, the finished graphic will be defined in view coordinates, for use as a decoration of type GraphicType.ViewBackground or GraphicType.ViewOverlay.  
origin undefined | Readonly<WritableXYAndZ> The origin of the particle collection in world coordinates.  
pickableId undefined | string If the particles are to be pickable, a unique identifier to associate with the resultant RenderGraphic.  
size number | Readonly<WritableXAndY> The default extents of the particle quad.  
texture RenderTexture The image mapped to each particle quad.  
transparency undefined | number The initial transparency of the particles as an integer in [0,255].  
viewport Viewport The viewport in which the particles will be drawn.  

Defined in

Last Updated: 16 April, 2024