QueryTileFeaturesOptions Interface

Options specifying how to query for visible Features by inspecting the Tiles selected for display by a Viewport. This method of determining visibility considers a feature "visible" if it is included in at least one tile selected for display and is not otherwise rendered invisible by the view's CategorySelectorState, SubCategoryAppearance overrides, FeatureOverrides, or other means.

@note If a clip volume is applied to the view, features contained in tiles that intersect the clip volume are considered visible regardless of whether their geometry would actually be entirely clipped out by the clip volume.

@see QueryVisibleFeaturesOptions.

Properties

Name Type Description
includeNonLocatable undefined | boolean If true, non-locatable features are considered visible.  
source "tiles" Union discriminator for QueryVisibleFeaturesOptions.  

Defined in

Last Updated: 15 March, 2024