VisibleFeature Interface

Represents a Feature determined to be visible within a Viewport.

@see Viewport.queryVisibleFeatures.

Properties

Name Type Description
elementId Readonly string The Id of the Element associated with the feature.  
geometryClass Readonly GeometryClass The class of geometry associated with the feature.  
iModel IModelConnection The iModel associated with the feature.  
modelId Readonly string The Id of the GeometricModel associated with the feature.  
subCategoryId Readonly string The Id of the SubCategory associated with the feature.  

Defined in

Last Updated: 15 March, 2024