convertTouchEndToButtonUp Method

Can be called by tools that wish to emulate releasing the mouse button for onTouchEnd or onTouchComplete.

convertTouchEndToButtonUp(ev: BeTouchEvent, button: BeButton = BeButton.Data): Promise<void>

@note Calls the tool's onMouseEndDrag method if convertTouchMoveStartToButtonDownAndMotion was called for onTouchMoveStart.

Parameter Type Description
ev BeTouchEvent  
button BeButton  

Returns - Promise<void>

Defined in

Last Updated: 16 April, 2024