dispatchImmediateUiSyncEvent Method

Method used by interactive tools to inform one or more UI components to refresh. This is typically used to update labels or icons associated with a specific tool. This method should be used when the caller wants the UI layer to process the sync event immediately. Use dispatchUiSyncEvent when the event may be triggered while other more important user interaction processing is required.

dispatchImmediateUiSyncEvent(specificSyncEventId?: string, toolId?: string): void

Parameter Type Description
specificSyncEventId string Optional sync event id. If not specified then "tool-admin-refresh-ui" is used.
toolId string Optional, will be used if specificSyncEventId is not specified. If used, the resulting sync event Id will be created using tool-admin-refresh-ui-${toolId}.toLowerCase()

Returns - void

Defined in

Last Updated: 16 April, 2024