dispatchUiSyncEvent Method

Method used by interactive tools to inform one or more UI components to refresh. This is typically used to update labels or icons associated with a specific tool. This method should be used when the caller wants the UI layer to process the sync event on a timer, waiting a few 100 ms, allowing other events that may require a UI refresh to be processed together.

dispatchUiSyncEvent(specificSyncEventId?: string, toolId?: string): void

Parameter Type Description
specificSyncEventId string Optional sync event id. If not specified then "tool-admin-refresh-ui" is used.
toolId string Optional, will be used if specificSyncEventId is not specified. If used, the resulting sync event Id will be created using tool-admin-refresh-ui-${toolId}.toLowerCase()

Returns - void

Defined in

Last Updated: 16 April, 2024