startDefaultTool Method

Starts the default PrimitiveTool, if any. Generally invoked automatically when other tools exit, so shouldn't be called directly.

startDefaultTool(): Promise<void>

@note The default tool, when specified, must be a subclass of PrimitiveTool. A call to startDefaultTool is required to terminate an active ViewTool or InputCollector and replace or clear the current PrimitiveTool. The default tool can not be a subclass of ViewTool as view tools replace each other and aren't suspended. This means exitTool would result in the active tool being undefined instead of making the default tool active. The tool's Tool.run method is invoked with arguments specified by defaultToolArgs.

@see defaultToolId to configure the default tool.

Returns - Promise

Defined in

Last Updated: 19 July, 2024