findExactMatch Method

Find a tool by its localized keyin.

findExactMatch(keyin: string): undefined |

@returns the Tool class, if an exact match is found, otherwise returns undefined.

@note Make sure the i18n resources are all loaded (e.g. await IModelApp.i81n.waitForAllRead()) before calling this method.

Parameter Type Description
keyin string the localized keyin string of the Tool.

Returns - undefined |

the Tool class, if an exact match is found, otherwise returns undefined.

Defined in

Last Updated: 16 April, 2024