onMouseStartDrag Method

Invoked when the cursor begins moving while a button is depressed.

onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled>

@returns Yes if event completely handled by tool and event should not be passed on to the IdleTool.

Parameter Type Description
ev BeButtonEvent  

Returns - Promise<EventHandled>

Yes if event completely handled by tool and event should not be passed on to the IdleTool.

Defined in

Last Updated: 16 April, 2024