AlternatingCCTreeBuilder Class

Context structure for building an AlternatingConvexClipTreeNode from a polygon.

  • The polygon is copied to the local m_points structure.
  • During construction, m_stack contains indices of a sequence of points with uniform concavity.

Methods

Name Description
buildHullAndInletsForPolygon(root: AlternatingCCTreeNode): boolean
     
    buildHullTree(root: AlternatingCCTreeNode): boolean
       
      collectHullChain(kStart: number, numK: number, sign: number): void    
      collectHullPointsInArray(points: Point3d[], kStart: number, numK: number, _sign: number): void    
      cyclicStackPoint(cyclicIndex: number): Point3d    
      extendHullChain(k: number, sign: number, pushAfterPops: boolean): void Pop from the stack until the sign condition is satisfied  
      indexAfter(i: number): number    
      indexBefore(i: number): number    
      pushIndex(primaryPointIndex: number): void    
      signFromStackTip(pointIndex: number, sign: number): "1" | "-1"    
      createPointsRef(points: Point3d[], result?: AlternatingCCTreeBuilder): AlternatingCCTreeBuilder Static    

      Properties

      Name Type Description
      indexOfMaxX Accessor ReadOnly number    
      period Accessor ReadOnly number    

      Defined in

      Last Updated: 15 March, 2024