Point3dArrayPolygonOps Class

Point3dArrayPolygonOps class contains static methods for typical operations on polygons carried as Point3d[]

Methods

Name Description
constructor(): Point3dArrayPolygonOps    
convexPolygonClipInPlace(plane: PlaneAltitudeEvaluator, xyz: Point3d[], work: undefined | Point3d[], tolerance: number = Geometry.smallMetricDistance): void Static Clip a polygon, returning the clip result in the same object.  
convexPolygonSplitInsideOutsidePlane(plane: PlaneAltitudeEvaluator, xyz: Point3d[], xyzIn: Point3d[], xyzOut: Point3d[], altitudeRange: Range1d): void Static Split a (convex) polygon into 2 parts.  
polygonPlaneCrossings(plane: PlaneAltitudeEvaluator, xyz: Point3d[], crossings: Point3d[]): void Static Return an array containing  

Defined in

Last Updated: 15 March, 2024