addNormal Method

Add (a clone of) a normal vector to the normal array.

addNormal(normal: Vector3d, priorIndexA?: number, priorIndexB?: number): number

@returns zero-based index of the added or duplicate normal.

Parameter Type Description
normal Vector3d the normal vector.
priorIndexA number first index to check for possible duplicate value.
priorIndexB number second index to check for possible duplicate value.

Returns - number

zero-based index of the added or duplicate normal.

Defined in

Last Updated: 13 May, 2024