terminateFacet Method

Announce the end of construction of a facet.

  • Optionally check for:
    • Same number of indices among all active index arrays -- point, normal, param, color
    • All indices are within bounds of the respective data arrays.
  • In error cases, all index arrays are trimmed back to the size when previous facet was terminated.
  • A return value of undefined is normal. Otherwise, a string array of error messages is returned.

terminateFacet(validateAllIndices: booleantrue): undefined | String[]

Parameter Type Description
validateAllIndices boolean  

Returns - undefined | String[]

Defined in

Last Updated: 13 May, 2024