tryTransformInPlace Method

Transform the mesh.

  • Apply the transform to points.
  • Apply the (inverse transpose of the) matrix part to normals.
  • If determinant of the transform matrix is negative, also
    • negate normals
    • reverse index order around each facet.

tryTransformInPlace(transform: Transform): boolean

Parameter Type Description
transform Transform  

Returns - boolean

Defined in

Last Updated: 13 May, 2024