areIndicesValid MethodStatic

Check validity of indices into a data array.

  • It is valid to have both indices and data undefined.
  • It is NOT valid for just one to be defined.
  • Index values at indices[indexPositionA <= i < indexPositionB] must be valid indices to the data array.

areIndicesValid(indices: undefined | number[], indexPositionA: number, indexPositionB: number, data: any, dataLength: number): boolean

Parameter Type Description
indices undefined | number[] array of indices.
indexPositionA number first index to test
indexPositionB number one past final index to test
data any data array
dataLength number length of data array

Returns - boolean

Defined in

Last Updated: 15 March, 2024