addGreedyTriangulationBetweenLineStrings Method

Create (and add to the builder) triangles that bridge the gap between two linestrings.

  • Each triangle will have 1 vertex on one of the linestrings and 2 on the other
  • Choice of triangles is heuristic, hence does not have a unique solution.
  • Logic to choice among the various possible triangle orders prefers
    • Make near-coplanar facets
    • make facets with good aspect ratio.
    • This is exercised with a limited number of lookahead points, i.e. greedy to make first-available decision.

addGreedyTriangulationBetweenLineStrings(pointsA: IndexedXYZCollection | Point3d[] | LineString3d, pointsB: IndexedXYZCollection | Point3d[] | LineString3d): void

Parameter Type Description
pointsA IndexedXYZCollection | Point3d[] | LineString3d points of first linestring.
pointsB IndexedXYZCollection | Point3d[] | LineString3d points of second linestring.

Returns - void

Defined in

Last Updated: 16 April, 2024