clipPolyface MethodStatic

Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet

  • This method parses the variant input types and calls a more specific method.
  • To get both inside and outside parts, use clipPolyfaceInsideOutside
  • WARNING: The new mesh is "points only".

clipPolyface(polyface: Polyface, clipper: ClipPlane | ConvexClipPlaneSet): undefined | Polyface

Parameter Type Description
polyface Polyface  
clipper ClipPlane | ConvexClipPlaneSet  

Returns - undefined | Polyface

Defined in

Last Updated: 13 May, 2024