clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders MethodStatic

Clip each facet of polyface to the the clippers.

  • Add inside, outside fragments to builderA, builderB
  • This does not consider params, normals, colors. Just points.
  • outputSelect determines how the clip output is structured
    • 0 outputs all shards -- this may have many interior edges.
    • 1 stitches shards together to get cleaner facets.

clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders(polyface: Polyface | PolyfaceVisitor, allClippers: UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelector: number1): void

Parameter Type Description
polyface Polyface | PolyfaceVisitor  
allClippers UnionOfConvexClipPlaneSets  
destination ClippedPolyfaceBuilders  
outputSelector number  

Returns - void

Defined in

Last Updated: 13 May, 2024