compress Method

Compress the instance by equating duplicate data.

  • Search for duplicates within points, normals, params, and colors.
  • Compress each data array.
  • Revise all indexing for the relocated data.

compress(tolerance: number = Geometry.smallMetricDistance): void

Parameter Type Description
tolerance number (optional) tolerance for clustering mesh vertices. Default is Geometry.smallMetricDistance.

Returns - void

Defined in

Last Updated: 16 April, 2024