constructor Method

Constructor for facets.

  • The various params control whether respective arrays are to be allocated.
  • If arrayData is provided, all other params are IGNORED.

PolyfaceData(needNormals: boolean = false, needParams: boolean = false, needColors: boolean = false, twoSided: boolean = false): PolyfaceData

Parameter Type Description
needNormals boolean  
needParams boolean  
needColors boolean  
twoSided boolean  

Returns - PolyfaceData

Defined in

Last Updated: 15 March, 2024