gatherIndexedData Method

  • Copy data from other to this.
  • This is the essence of transferring coordinates spread throughout a large polyface into a visitor's single facet.
  • "other" is the large polyface
  • "this" is the visitor
  • does NOT copy face data - visitors reference the FacetFaceData array for the whole polyface!!

gatherIndexedData(other: PolyfaceData, index0: number, index1: number, numWrap: number): void

Parameter Type Description
other PolyfaceData polyface data being mined.
index0 number start index in other's index arrays
index1 number end index (one beyond last data accessed0 in other's index arrays
numWrap number number of points to replicate as wraparound.

Returns - void

Defined in

Last Updated: 15 March, 2024