reverseIndicesSingleFacet Method

Reverse the indices for the specified facet in the index arrays (pointIndex, normalIndex, paramIndex, colorIndex, and edgeVisible).

reverseIndicesSingleFacet(facetIndex: number, facetStartIndex: number[]): void

Parameter Type Description
facetIndex number index of the facet to reverse. The entries of each index array to be reversed are found at
facetStartIndex[facetIndex] <= i < facetStartIndex[facetIndex + 1].
facetStartIndex number[] start indices of consecutive facets, e.g., an IndexedPolyface's _facetStart array.
See PolyfaceData.reverseIndices.

Returns - void

Defined in

Last Updated: 16 April, 2024