announceBoundaryEdges MethodStatic

Test if the facets in source occur in perfectly mated pairs, as is required for a closed manifold volume. If not, extract the boundary edges as lines.

announceBoundaryEdges(source: undefined | Polyface | PolyfaceVisitor, announceEdge: (pointA: Point3d, pointB: Point3d, indexA: number, indexB: number, facetIndex: number) => void, includeTypical: boolean = true, includeMismatch: boolean = true, includeNull: boolean = true): void

Parameter Type Description
source undefined | Polyface | PolyfaceVisitor polyface or visitor
announceEdge (pointA: Point3d, pointB: Point3d, indexA: number, indexB: number, facetIndex: number) => void function to be called with each boundary edge. The announcement is start and end points, start and end indices, and facet index.
includeTypical boolean true to announce typical boundary edges with a single incident facet
includeMismatch boolean true to announce edges with more than 2 incident facets
includeNull boolean true to announce edges with identical start and end vertex indices.

Returns - void

Defined in

Last Updated: 16 April, 2024