announceSilhouetteEdges MethodStatic

Invoke the callback on each manifold edge whose adjacent facet normals form vectorToEye dot products with opposite sign.

  • The callback is not called on boundary edges.

announceSilhouetteEdges(source: Polyface | PolyfaceVisitor, announce: (pointA: Point3d, pointB: Point3d, vertexIndexA: number, vertexIndexB: number, facetIndex: number) => void, vectorToEye: Vector3d, sideAngle: Angle = ...): void

Parameter Type Description
source Polyface | PolyfaceVisitor facets
announce (pointA: Point3d, pointB: Point3d, vertexIndexA: number, vertexIndexB: number, facetIndex: number) => void callback function invoked on manifold silhouette edges
vectorToEye Vector3d normal of plane in which to compute silhouette edges
sideAngle Angle angular tolerance for perpendicularity test

Returns - void

Defined in

Last Updated: 16 April, 2024