cloneWithMaximalPlanarFacets MethodStatic

Return a mesh with

  • clusters of adjacent, coplanar facets merged into larger facets.
  • other facets included unchanged.

cloneWithMaximalPlanarFacets(mesh: Polyface | PolyfaceVisitor, maxSmoothEdgeAngle?: Angle): undefined | IndexedPolyface

Parameter Type Description
mesh Polyface | PolyfaceVisitor existing mesh or visitor
maxSmoothEdgeAngle Angle maximum dihedral angle across an edge between facets deemed coplanar. If undefined, uses Geometry.smallAngleRadians.

Returns - undefined | IndexedPolyface

Defined in

Last Updated: 16 April, 2024