computePrincipalAreaMoments MethodStatic

Compute area moments for the mesh. In the returned MomentData:

  • origin is the centroid.
  • localToWorldMap has the origin and principal directions
  • radiiOfGyration radii for rotation around the x,y,z axes.

computePrincipalAreaMoments(source: Polyface): undefined | MomentData

Parameter Type Description
source Polyface  

Returns - undefined | MomentData

Defined in

Last Updated: 16 April, 2024