sweepLinestringToFacetsXYReturnChains MethodStatic

Deprecated  in 4.x. Use PolyfaceQuery.sweepLineStringToFacets to get further options.

Find segments (within the linestring) which project to facets.

  • Return chains.
  • This calls PolyfaceQuery.sweepLineStringToFacets with options created by const options = SweepLineStringToFacetsOptions.create(Vector3d.unitZ(), Angle.createSmallAngle(),true, true, true, true);

sweepLinestringToFacetsXYReturnChains(linestringPoints: GrowableXYZArray, polyface: Polyface): LineString3d[]

Parameter Type Description
linestringPoints GrowableXYZArray  
polyface Polyface  

Returns - LineString3d[]

Defined in

Last Updated: 16 April, 2024