sweepLinestringToFacetsXYReturnLines MethodStatic

Deprecated  in 4.x. Use PolyfaceQuery.sweepLineStringToFacets to get further options.

Find segments (within the linestring) which project to facets.

  • Return collected line segments.
  • This calls PolyfaceQuery.sweepLineStringToFacets with options created by const options = SweepLineStringToFacetsOptions.create(Vector3d.unitZ(), Angle.createSmallAngle(),false, true, true, true);

sweepLinestringToFacetsXYReturnLines(linestringPoints: GrowableXYZArray, polyface: Polyface): LineSegment3d[]

Parameter Type Description
linestringPoints GrowableXYZArray  
polyface Polyface  

Returns - LineSegment3d[]

Defined in

Last Updated: 16 April, 2024