MobileApp Class

Methods

Name Description
constructor(): MobileApp    
callBackend<T extends AsyncMethodsOf<MobileAppFunctions>>(methodName: T, ...args: Parameters<>): Promise<PromiseReturnType<>> Static    
startup(opts?: MobileAppOpts): Promise<void> Static    

Properties

Name Type Description
isValid Accessor StaticReadOnly boolean    
onAuthAccessTokenChanged Static BeEvent<(accessToken: undefined | string, expirationDate: undefined | string) => void>    
onEnterBackground Static BeEvent<() => void>    
onEnterForeground Static BeEvent<() => void>    
onMemoryWarning Static BeEvent<() => void>    
onOrientationChanged Static BeEvent<() => void>    
onWillTerminate Static BeEvent<() => void>    

Defined in

Last Updated: 16 April, 2024