ContextMenuItemProps Interface

Properties for the ContextMenuItem component

Extends

  • Omit<React.AllHTMLAttributes<HTMLDivElement>, "disabled" | "hidden">
  • CommonProps

Properties

Name Type Description
badgeType BadgeType | undefined Badge to be overlaid on the item.  
disabled boolean | ConditionalBooleanValue Disables any onSelect calls, hover/keyboard highlighting, and grays item.  
hidden boolean | ConditionalBooleanValue Indicates whether the item is visible or hidden.  
hideIconContainer boolean | undefined Hide the icon container.  
icon IconSpec | undefined Icon to display in the left margin.  
iconRight IconSpec | undefined Icon to display in the right margin.  
isSelected boolean | undefined    
onSelect (event: any) => any | undefined    

Inherited properties

Name Type Inherited from Description
itemId string | undefined CommonProps Optional unique identifier for item.

Defined in

Last Updated: 13 May, 2024