MessageBoxProps Interface

Properties for the MessageBox component

Extends

Properties

Name Type Description
buttonCluster DialogButtonDef[] List of DialogButtonDef objects specifying buttons and associated onClick events  
children undefined | ReactNode Message content  
contentClassName undefined | string Custom CSS class name for the content  
contentStyle undefined | CSSProperties Custom CSS Style for the content  
height string | number initial height of dialog.  
minHeight undefined | number minimum height that the dialog may be resized to.  
minWidth undefined | number minimum width that the dialog may be resized to.  
modal undefined | boolean Whether to show background overlay.  
onClose undefined | () => void    
onEscape undefined | () => void    
opened boolean whether to show dialog or not  
severity MessageSeverity Severity of MessageBox  
title string | ReactElement<any, string | JSXElementConstructor<any>> Title to show in title bar of dialog  
width string | number initial width of dialog.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 05 April, 2024