RadialMenu Class
Deprecated in 4.14.0. Use ContextMenu or [[iTwinUI dropdown menu]] instead.
A context menu arranged in a radial layout.
Extends
- React.Component<RadialMenuProps, RadialMenuState>
Methods
Name | Description | |
---|---|---|
constructor(props: RadialMenuProps): RadialMenu | ||
componentDidMount(): void | Called immediately after a component is mounted. | |
componentWillUnmount(): void | Called immediately before a component is destroyed. | |
render(): React.ReactElement<any, string | React.JSXElementConstructor<any>> | ||
select(): void | Manually call onSelect of highlighted button. |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static | Partial<RadialMenuProps> | ||
state Readonly | Readonly<RadialMenuState> |
Defined in
Last Updated: 17 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.