SettingsManager Class

Settings Manager class. Hold registration of settings providers and supplies events for the provided settings pages to listen.

Methods

Name Description
constructor(): SettingsManager    
activateSettingsTab(settingsTabId: string): void Called by application when an tool, keyin, or other process want to change the active settings tab/page giving the current tab/page and opportunity  
addSettingsProvider(settingsProvider: SettingsTabsProvider): void    
closeSettingsContainer(closeFunc: (args: any) => void, closeFuncArgs?: any): void Called by application when the Settings Container is to be closed.  
getSettingEntries(stageId: string, stageUsage: string): SettingsTabEntry[] Get an array of SettingsTabEntry objects to populate the settings container.  
removeSettingsProvider(providerId: string): boolean    

Properties

Name Type Description
onProcessSettingsContainerClose Readonly ProcessSettingsContainerCloseEvent Event raised when the settings container will be closed.  
onProcessSettingsTabActivation Readonly ProcessSettingsTabActivationEvent Event raised solely for a settings page to monitor so it can save its settings before continuing tab activation.  
onSettingsProvidersChanged Readonly SettingsProvidersChangedEvent Event raised when SettingsProviders are changed.  
providers Accessor undefined    

Defined in

Last Updated: 21 March, 2024