IconHelper Class

Icon Helper Class used to store the data needed to generate an for use in any control that shows an icon.

Methods

Name Description
constructor(): IconHelper    
getIconData(iconSpec: IconSpec, internalData?: Map<string, any>): string | ConditionalStringValue Static Returns an icon definition that can be stored in an abstract item definition.  
getIconReactNode(icon: ReactNode | ConditionalIconItem | ConditionalStringValue, internalData?: Map<string, any>): ReactNode Static Returns an ReactNode from the many ways an icon can be specified.  

Properties

Name Type Description
conditionalIconItemKey Accessor StaticReadOnly string    
reactIconKey Accessor StaticReadOnly string    

Defined in

Last Updated: 05 April, 2024