getPropertiesSync Method

Iterates all properties, including the ones merged from base classes and mixins. To obtain only local properties, use the 'properties' field. Since this is an expensive operation, results will be cached after first call.

getPropertiesSync(resetCache: boolean = false): Property[]

Parameter Type Description
resetCache boolean if true, any previously cached results will be dropped and cache will be rebuilt

Returns - Property[]

Defined in

Last Updated: 16 April, 2024