Metadata

Definitions of classes and interfaces that represent all EC elements.

Classes

Name Description  
ArrayProperty  
Constant A Constant is a specific type of Unit that represents a number.  
CustomAttributeClass A Typescript class representation of an ECCustomAttributeClass.  
ECClass A common abstract class for all of the ECClass types.  
ECName The name of an item in a Schema, encoded to meet restrictions on the characters usable in such names.  
ECVersion  
EntityClass A Typescript class representation of an ECEntityClass.  
Enumeration A Typescript class representation of an ECEnumeration.  
EnumerationArrayProperty  
EnumerationProperty  
Format  
InvertedUnit An InvertedUnit is a specific type of Unit that describes the inverse of a single Unit whose dimensional derivation is unit-less.  
KindOfQuantity A Typescript class representation of a KindOfQuantity.  
Mixin A Typescript class representation of a Mixin.  
NavigationProperty  
OverrideFormat Overrides of a Format, from a Schema, and is SchemaItem that is used specifically on KindOfQuantity.  
Phenomenon  
PrimitiveArrayProperty  
PrimitiveOrEnumPropertyBase  
PrimitiveProperty  
Property A common abstract class for all ECProperty types.  
PropertyCategory  
RelationshipClass A Typescript class representation of a ECRelationshipClass.  
RelationshipConstraint A Typescript class representation of a ECRelationshipConstraint.  
RelationshipMultiplicity  
Schema  
SchemaItem An abstract class that supplies all of the common parts of a SchemaItem.  
SchemaItemKey The SchemaItemKey contains a SchemaItem's name and SchemaKey.  
SchemaKey The SchemaKey contains a Schemas name and version.  
StructArrayProperty  
StructClass A Typescript class representation of an ECStructClass.  
StructProperty  
Unit An abstract class that adds the ability to define Units and everything that goes with them, within an ECSchema as a  
UnitSystem  

Enumerations

Name Description  
CustomAttributeContainerType Defines the valid CustomAttribute container types.  
ECClassModifier  
ECObjectsStatus  
PrimitiveType Primitive data types for ECProperties.  
PropertyType  
RelationshipEnd Identifer for an ECRelationshipConstraint.  
SchemaItemType  
SchemaMatchType Defines what sort of match should be used when locating a schema.  
StrengthDirection  
StrengthType  

Global Functions

Name Description  
classModifierToString  
containerTypeToString Creates a string representing a valid CustomAttributeContainerType.  
parseClassModifier Parses the provided string into an ECClassModifier if the string is a valid modifier.  
parseCustomAttributeContainerType Parses the given string into the appropriate CustomAttributeContainerType if the string is valid.  
parsePrimitiveType Tries to parse the given string as one of the 10 primitive types.  
parseRelationshipEnd  
parseSchemaItemType Tries to parse the given string as one of the 8 schema item types.  
parseStrength Takes a string representing a StrengthType, will parse it and return the corresponding StrengthType.  
parseStrengthDirection  
primitiveTypeToString  
propertyTypeToString  
relationshipEndToString  
schemaItemTypeToString Converts a valid SchemaItemType to a display string.  
strengthDirectionToString  
strengthToString  

Interfaces

Name Description  
ArrayPropertyProps  
ClassProps  
ConstantProps  
CustomAttribute  
CustomAttributeClassProps  
CustomAttributeContainerProps  
EntityClassProps  
EnumerationPropertyProps  
EnumerationProps  
Enumerator  
EnumeratorProps  
InvertedUnitProps  
KindOfQuantityProps  
MixinProps  
NavigationPropertyProps  
PhenomenonProps  
PrimitiveArrayPropertyProps  
PrimitiveOrEnumPropertyBaseProps  
PrimitivePropertyProps  
PropertyCategoryProps  
PropertyProps  
RelationshipClassProps  
RelationshipConstraintProps  
SchemaInfo Holds the SchemaKeys for a schema and it's references.  
SchemaItemOverrideFormatProps  
SchemaItemProps  
SchemaItemUnitProps  
SchemaKeyProps JSON Object interface used to deserialize into a SchemaKey.  
SchemaProps  
SchemaReferenceProps  
StructArrayPropertyProps  
StructPropertyProps  
WithSchemaKey  

Namespaces

Name Description  
PropertyTypeUtils  

Type Aliases

Name Description  
AnyArrayProperty  
AnyClass  
AnyClassProps  
AnyECType  
AnyEnumerationProperty  
AnyEnumerator  
AnyPrimitiveProperty  
AnyProperty  
AnyPropertyProps  
AnySchemaItem  
AnySchemaItemProps  
AnyStructProperty  
LazyLoadedConstant  
LazyLoadedCustomAttributeClass  
LazyLoadedECClass  
LazyLoadedEntityClass  
LazyLoadedEnumeration  
LazyLoadedFormat  
LazyLoadedInvertedUnit  
LazyLoadedKindOfQuantity  
LazyLoadedMixin  
LazyLoadedPhenomenon  
LazyLoadedPropertyCategory  
LazyLoadedRelationshipClass  
LazyLoadedRelationshipConstraintClass  
LazyLoadedSchema  
LazyLoadedSchemaItem  
LazyLoadedStructClass  
LazyLoadedUnit  
LazyLoadedUnitSystem  
SchemaItemFormatProps  
StructClassProps  
UnitSystemProps  

Last Updated: 12 February, 2024