toJSON Method

Save this Classes properties to an object for serializing to JSON.

toJSON(standalone: boolean = false, includeSchemaVersion: boolean = false): ClassProps

Parameter Type Description
standalone boolean Serialization includes only this object (as opposed to the full schema).
includeSchemaVersion boolean Include the Schema's version information in the serialized object.

Returns - ClassProps

Defined in

Last Updated: 16 April, 2024