traverseBaseClassesSync Method

Synchronously traverses through the inheritance tree, using depth-first traversal, calling the given callback function for each base class encountered.

traverseBaseClassesSync(callback: (ecClass: ECClass, arg?: any) => boolean, arg?: any): boolean

Parameter Type Description
callback (ecClass: ECClass, arg?: any) => boolean The function to call for each base class in the hierarchy.
arg any An argument that will be passed as the second parameter to the callback function.

Returns - boolean

Defined in

Last Updated: 16 April, 2024