lookupItem Method

Attempts to find a schema item within this schema or a (directly) referenced schema

lookupItem<T extends SchemaItem<T>>(key: string | Readonly<SchemaItemKey>): Promise<undefined | T>

Parameter Type Description
key string | Readonly<SchemaItemKey> The full name or a SchemaItemKey identifying the desired item.

Returns - Promise<undefined | T>

Defined in

Last Updated: 16 April, 2024