parseFullName MethodStatic

Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.

parseFullName(fullName: string): [string, string]

@note The schema name can be a schema alias.

@returns A tuple of the parsed Schema name and Schema Item name. If the full name does not contain a '.' or ':', the second string in the tuple will returned the exact string pass in.

Parameter Type Description
fullName string The full name to be parsed.

Returns - [string, string]

A tuple of the parsed Schema name and Schema Item name. If the full name does not contain a '.' or ':', the second string in the tuple will returned the exact string pass in.

Defined in

Last Updated: 16 April, 2024