LinearlyLocatedAttribution Class

Base class for Spatial Location Element subclasses representing properties whose value is located along a Linear-Element and only applies to a portion of an Element.

Extends

Methods

Name Description
constructor(props: LinearlyLocatedAttributionProps, iModel: IModelDb): LinearlyLocatedAttribution    
getLinearElementId(): undefined | string    

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d SpatialLocationElement  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected SpatialLocationElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected SpatialLocationElement  
delete(): void SpatialLocationElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom?: boolean): void SpatialLocationElement Call a function for each property of this Entity.
SpatialLocationElement Get the class metadata for this element.
getDisplayLabel(): string SpatialLocationElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any SpatialLocationElement Get a JSON property of this element, by namespace
getPlacementTransform(): Transform SpatialLocationElement Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set SpatialLocationElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet SpatialLocationElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] SpatialLocationElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any SpatialLocationElement Get a set of JSON user properties by namespace
insert(): string SpatialLocationElement Insert this Element into the iModel.
is2d(): this is GeometricElement2d SpatialLocationElement Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d SpatialLocationElement Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void SpatialLocationElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void SpatialLocationElement  
setUserProperties(nameSpace: string, value: any): void SpatialLocationElement Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricElement3dProps SpatialLocationElement  
update(): void SpatialLocationElement Update this Element in the iModel.
is(otherClass: undefined): boolean Static SpatialLocationElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic SpatialLocationElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic SpatialLocationElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic SpatialLocationElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic SpatialLocationElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic SpatialLocationElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic SpatialLocationElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic SpatialLocationElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic SpatialLocationElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic SpatialLocationElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic SpatialLocationElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic SpatialLocationElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic SpatialLocationElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic SpatialLocationElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic SpatialLocationElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic SpatialLocationElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic SpatialLocationElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic SpatialLocationElement Called after an Element was updated.

Properties

Name Type Description
attributedElement undefined | ILinearlyLocatedAttributesElement    

Inherited properties

Name Type Inherited from Description
category string SpatialLocationElement The Id of the Category for this GeometricElement.
classFullName Accessor ReadOnly string SpatialLocationElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string SpatialLocationElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string SpatialLocationElement The name of the BIS class associated with this class.
code Code SpatialLocationElement The Code for this element
elementGeometryBuilderParams undefined | ElementGeometryBuilderParams SpatialLocationElement How to build the element's GeometryStream.
federationGuid undefined | string SpatialLocationElement A FederationGuid assigned to this element by some other federated database
geom undefined | GeometryStreamProps SpatialLocationElement The GeometryStream for this GeometricElement.
id string SpatialLocationElement The Id of this Entity.
iModel IModelDb SpatialLocationElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" SpatialLocationElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly { T } SpatialLocationElement Optional json properties of this element.
model Readonly string SpatialLocationElement The ModelId of the Model containing this element
parent undefined | RelatedElement SpatialLocationElement The parent element, if present, of this element.
placement Placement3d SpatialLocationElement  
requiredReferenceKeys StaticReadonly undefined SpatialLocationElement  
schema Static undefined SpatialLocationElement The Schema that defines this class.
schemaName Accessor ReadOnly string SpatialLocationElement The name of the BIS Schema that defines this class
typeDefinition undefined | TypeDefinition SpatialLocationElement  
userLabel undefined | string SpatialLocationElement A user-assigned label for this element.

Defined in

Last Updated: 15 March, 2024