LinearlyReferencedAtLocationAspectProps Interface

Properties of a LinearlyReferencedAtLocation

Extends

Inherited properties

Name Type Inherited from Description
atPosition DistanceExpressionProps LinearlyReferencedAtLocationProps  
classFullName string ElementAspectProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
element RelatedElementProps ElementAspectProps  
fromReferent undefined | RelatedElementProps LinearlyReferencedAtLocationProps  
id undefined | string ElementAspectProps The Id of the entity.
isInstanceOfEntity Readonly undefined | undefined ElementAspectProps A non-existent property used to discriminate between EntityProps and Entity.
jsonProperties undefined | { T } ElementAspectProps Optional json properties of this Entity.

Defined in

Last Updated: 16 April, 2024