NodeCliAuthorizationClient Class

Utility to generate OIDC/OAuth tokens for command-line applications This client is intended for developer tooling and does not aspire to provide the full set of functionality needed for a user-facing app.

Implements

Methods

Name Description
constructor(config: NodeCliAuthorizationConfiguration): NodeCliAuthorizationClient    
getAccessToken(): Promise<string> Returns a promise that resolves to the AccessToken of the currently authorized user.  
Attempts to authorize the current user, and resolves when the authorization process is complete.  
signOut(): Promise<void> Clear cached credential (if any).  

Defined in

Last Updated: 03 April, 2024