ContentFlags Enumeration

Flags that control content format.

Members

Name Value Description
DescriptorOnly Produce content descriptor that is not intended for querying content. Allows the implementation to omit certain
operations to make obtaining content descriptor faster.
DistinctValues Content has only distinct values
IncludeInputKeys Set related input keys on Item objects when creating content. This helps identify which Item is associated to which
given input key at the cost of performance creating those items.
KeysOnly Each content record only has InstanceKey and no data
MergeResults All content records are merged into a single record (see Merging values)
NoFields Doesn't create property or calculated fields. Can be used in conjunction with ContentFlags.ShowLabels.
ShowImages Each content record additionally has an image id
ShowLabels Each content record additionally has a display label

Defined in

Last Updated: 15 March, 2024